#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[(?:[[:alnum:]]+[[:blank:]]*)?[0-9]+]"
Local $sString = "[76][note 7] just like traditional Hinduism regards the Vedas "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)