const regex = /\[(?:[[:alnum:]]+[[:blank:]]*)?[0-9]+]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(?:[[:alnum:]]+[[:blank:]]*)?[0-9]+]', 'g')
const str = `[76][note 7] just like traditional Hinduism regards the Vedas `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);