use strict;
my $str = '[76][note 7] just like traditional Hinduism regards the Vedas ';
my $regex = qr/\[(?:[[:alnum:]]+[[:blank:]]*)?[0-9]+]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";