$re = '/\[(?:[[:alnum:]]+[[:blank:]]*)?[0-9]+]/';
$str = '[76][note 7] just like traditional Hinduism regards the Vedas ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;