package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(?:[[:alnum:]]+[[:blank:]]*)?[0-9]+]`)
var str = `[76][note 7] just like traditional Hinduism regards the Vedas `
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}