import Foundation
let pattern = #"\[(?:[[:alnum:]]+[[:blank:]]*)?[0-9]+]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[76][note 7] just like traditional Hinduism regards the Vedas "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)