re = /\[(?:[[:alnum:]]+[[:blank:]]*)?[0-9]+]/
str = '[76][note 7] just like traditional Hinduism regards the Vedas '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result