// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[(?:[[:alnum:]]+[[:blank:]]*)?[0-9]+]").unwrap();
let string = "[76][note 7] just like traditional Hinduism regards the Vedas ";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}