using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?:[[:alnum:]]+[[:blank:]]*)?[0-9]+]";
string substitution = @"";
string input = @"[76][note 7] just like traditional Hinduism regards the Vedas ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}