#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?=^[A-Z]{3}[0-9]{2}[A-Z0-9]{8}[0-9]{2}$)" & @CRLF & _
"helloJellofellow" & @CRLF & _
"" & @CRLF & _
"600566604081"
Local $sString = "hel01Jeloofel10" & @CRLF & _
""
Local $sSubst = "600566604081"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)