const regex = new RegExp('(?=^[A-Z]{3}[0-9]{2}[A-Z0-9]{8}[0-9]{2}$)
helloJellofellow
600566604081', '')
const str = `hel01Jeloofel10
`;
const subst = `600566604081`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);