re = /(?=^[A-Z]{3}[0-9]{2}[A-Z0-9]{8}[0-9]{2}$)
helloJellofellow
600566604081/
str = 'hel01Jeloofel10
'
subst = '600566604081'
result = str.sub(re, subst)
# Print the result of the substitution
puts result