use strict;
my $str = 'hel01Jeloofel10
';
my $regex = qr/(?=^[A-Z]{3}[0-9]{2}[A-Z0-9]{8}[0-9]{2}$)
helloJellofellow
600566604081/p;
my $subst = '600566604081';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";