using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^[A-Z]{3}[0-9]{2}[A-Z0-9]{8}[0-9]{2}$)
helloJellofellow
600566604081";
string substitution = @"600566604081";
string input = @"hel01Jeloofel10
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}