import re
regex = re.compile((r"(?=^[A-Z]{3}[0-9]{2}[A-Z0-9]{8}[0-9]{2}$)\n"
r"helloJellofellow\n\n"
r"600566604081"))
test_str = ("hel01Jeloofel10\n")
subst = "600566604081"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)