import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^[A-Z]{3}[0-9]{2}[A-Z0-9]{8}[0-9]{2}$)\n"
+ "helloJellofellow\n\n"
+ "600566604081";
final String string = "hel01Jeloofel10\n";
final String subst = "600566604081";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}