import Foundation
let pattern = #"""
(?=^[A-Z]{3}[0-9]{2}[A-Z0-9]{8}[0-9]{2}$)
helloJellofellow
600566604081
"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
hel01Jeloofel10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"600566604081"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}