# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(.+)\]\((\\/.+)\)/<a href='\2'>\1<\/a>/g;t' <<< "This is a [link](/url)
This is a <a href='/url'>link</a>"