$re = '/\[(.+)\]\((\/.+)\)/';
$str = 'This is a [link](/url)
This is a <a href=\'/url\'>link</a>';
$subst = "<a href='\2'>\1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;