using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(.+)\]\((\/.+)\)";
string substitution = @"<a href='\2'>\1</a>";
string input = @"This is a [link](/url)
This is a <a href='/url'>link</a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}