// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[(.+)\]\((\/.+)\)").unwrap();
let string = "This is a [link](/url)
This is a <a href='/url'>link</a>";
let substitution = "<a href='\\2'>\\1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}