import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(.+)\\]\\((\\/.+)\\)";
final String string = "This is a [link](/url)\n\n"
+ "This is a <a href='/url'>link</a>";
final String subst = "<a href='\\2'>\\1</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}