import Foundation
let pattern = #"\[(.+)\]\((\/.+)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
This is a [link](/url)
This is a <a href='/url'>link</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href='\2'>\1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)