#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[(.+)\]\((\/.+)\)"
Local $sString = "This is a [link](/url)" & @CRLF & _
"" & @CRLF & _
"This is a <a href='/url'>link</a>"
Local $sSubst = "<a href='\2'>\1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)