package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(.+)\]\((\/.+)\)`)
var str = `This is a [link](/url)
This is a <a href='/url'>link</a>`
var substitution = "<a href='\2'>\1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}