use strict;
my $str = 'This is a [link](/url)
This is a <a href=\'/url\'>link</a>';
my $regex = qr/\[(.+)\]\((\/.+)\)/p;
my $subst = '<a href=\'\\2\'>\\1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";