re = /\[(.+)\]\((\/.+)\)/
str = 'This is a [link](/url)
This is a <a href=\'/url\'>link</a>'
subst = '<a href=\'\\2\'>\\1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result