# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^?]+.*?&?q=([^$|&]+)//g;t' <<< "/myweb/search?s=islamic_sources&q=test
/myweb/search?q=test
/myweb/search?q=test&g=sth"