$re = '/^[^?]+.*?&?q=([^$|&]+)/';
$str = '/myweb/search?s=islamic_sources&q=test
/myweb/search?q=test
/myweb/search?q=test&g=sth';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;