import re
regex = re.compile(r"^[^?]+.*?&?q=([^$|&]+)")
test_str = ("/myweb/search?s=islamic_sources&q=test\n"
"/myweb/search?q=test\n"
"/myweb/search?q=test&g=sth")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)