#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^[^?]+.*?&?q=([^$|&]+)"
Local $sString = "/myweb/search?s=islamic_sources&q=test" & @CRLF & _
"/myweb/search?q=test" & @CRLF & _
"/myweb/search?q=test&g=sth"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)