import Foundation
let pattern = #"^[^?]+.*?&?q=([^$|&]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/myweb/search?s=islamic_sources&q=test
/myweb/search?q=test
/myweb/search?q=test&g=sth
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)