using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^?]+.*?&?q=([^$|&]+)";
string substitution = @"";
string input = @"/myweb/search?s=islamic_sources&q=test
/myweb/search?q=test
/myweb/search?q=test&g=sth";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}