# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(\.[0-9]*[1-9])|\.)0+$/\1/gm;t' <<< "0.0002300
10.0020300
100.00
1000
0.0
0 "