use strict;
my $str = '0.0002300
10.0020300
100.00
1000
0.0
0 ';
my $regex = qr/(?:(\.[0-9]*[1-9])|\.)0+$/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";