// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:(\.[0-9]*[1-9])|\.)0+$").unwrap();
let string = "0.0002300
10.0020300
100.00
1000
0.0
0 ";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}