using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(\.[0-9]*[1-9])|\.)0+$";
string substitution = @"\1";
string input = @"0.0002300
10.0020300
100.00
1000
0.0
0 ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}