package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(\.[0-9]*[1-9])|\.)0+$`)
var str = `0.0002300
10.0020300
100.00
1000
0.0
0 `
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}