const regex = new RegExp('(?:(\\.[0-9]*[1-9])|\\.)0+$', 'gm')
const str = `0.0002300
10.0020300
100.00
1000
0.0
0 `;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);