import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(\\.[0-9]*[1-9])|\\.)0+$";
final String string = "0.0002300\n"
+ "10.0020300\n"
+ "100.00\n"
+ "1000\n"
+ "0.0\n"
+ "0 ";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}