# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(\.[0-9]*[1-9])|\.)0+$"
test_str = ("0.0002300\n"
"10.0020300\n"
"100.00\n"
"1000\n"
"0.0\n"
"0 ")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.