#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(\.[0-9]*[1-9])|\.)0+$"
Local $sString = "0.0002300" & @CRLF & _
"10.0020300" & @CRLF & _
"100.00" & @CRLF & _
"1000" & @CRLF & _
"0.0" & @CRLF & _
"0 "
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)