using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"export function(.*)(\(.*\))\s{\n.*return.*{((.*\n){3,9})}";
string substitution = @"const $1 = $2 =>\n actionCreator($3))";
string input = @"export function crap(one,two,three) {
return {
one,
two,
three
}
}
export function crapTwo(one,two,three) {
return {
one,
two,
three
}
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}