use strict;
my $str = 'export function crap(one,two,three) {
return {
one,
two,
three
}
}
export function crapTwo(one,two,three) {
return {
one,
two,
three
}
}';
my $regex = qr/export function(.*)(\(.*\))\s{\n.*return.*{((.*\n){3,9})}/p;
my $subst = 'const $1 = $2 =>\\n actionCreator($3))';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";