import re
regex = re.compile(r"export function(.*)(\(.*\))\s{\n.*return.*{((.*\n){3,9})}")
test_str = ("export function crap(one,two,three) {\n"
" return {\n"
" one,\n"
" two,\n"
" three\n"
" }\n"
"}\n\n"
"export function crapTwo(one,two,three) {\n"
" return {\n"
" one,\n"
" two,\n"
" three\n"
" }\n"
"}")
subst = "const $1 = $2 =>\\n actionCreator($3))"
result = regex.sub(subst, test_str)
if result:
print(result)