package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`export function(.*)(\(.*\))\s{\n.*return.*{((.*\n){3,9})}`)
var str = `export function crap(one,two,three) {
return {
one,
two,
three
}
}
export function crapTwo(one,two,three) {
return {
one,
two,
three
}
}`
var substitution = "const $1 = $2 =>\n actionCreator($3))"
fmt.Println(re.ReplaceAllString(str, substitution))
}