const regex = /export function(.*)(\(.*\))\s{\n.*return.*{((.*\n){3,9})}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('export function(.*)(\\(.*\\))\\s{\\n.*return.*{((.*\\n){3,9})}', 'g')
const str = `export function crap(one,two,three) {
return {
one,
two,
three
}
}
export function crapTwo(one,two,three) {
return {
one,
two,
three
}
}`;
const subst = `const $1 = $2 =>\n actionCreator($3))`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);