// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"export function(.*)(\(.*\))\s{\n.*return.*{((.*\n){3,9})}").unwrap();
let string = "export function crap(one,two,three) {
return {
one,
two,
three
}
}
export function crapTwo(one,two,three) {
return {
one,
two,
three
}
}";
let substitution = "const $1 = $2 =>\\n actionCreator($3))";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}