re = /export function(.*)(\(.*\))\s{\n.*return.*{((.*\n){3,9})}/
str = 'export function crap(one,two,three) {
return {
one,
two,
three
}
}
export function crapTwo(one,two,three) {
return {
one,
two,
three
}
}'
subst = 'const $1 = $2 =>\\n actionCreator($3))'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result