# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|[^.])\b(ISomething)\b/$1Namespace.$2/g;t' <<< "Api.Resources.Things.Bits.ISomething //doesn't match
something : ISomething
List<ISomething>
something:ISomething
isomething "